Knowledgebase: 2) Frog 3
Frog 3 - Browser Compatibility
Posted by , Last modified by on 21 August 2014 10:25 AM

The Frog 3 learning platform is fully supported on:

Internet Explorer (latest version)

Internet Explorer (version previous to latest release)

Firefox (latest version)

Google Chrome (latest version)

 

As of writing this article that will be IE 10, IE11, Firefox 31.0, Chrome 36.0.1985.143 m

 

 Browser Support

 

(4 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below (we use this to prevent automated submissions).